*
News: SMF - Just Installed!


Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

Node Showing Out of Compliance but isn't 2427

Super Newbie Posts: 4 Karma: +1/-0 *
Node Showing Out of Compliance but isn't
« on: September 04, 2013, 01:13:20 PM »
Hello all,

I have a node that is listed as out of compliance but when I run the upgrade it says that the firmware package trying to be applied is at a greater or equal level.

See output below. Does anyone have a fix or suggestion for this?

August 21, 2013 1:12:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD633I The Installation Staging task has finished processing system "GVICESXI02".
August 21, 2013 1:12:27 PM EDT-Level:150-MEID:0--MSG: ATKUPD630I The update installation staging has completed.
August 21, 2013 1:12:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD760I Start processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:14:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:15:30 PM EDT-Level:50-MEID:56886--MSG: Current firmware level is equal or better for one or more controllers.
August 21, 2013 1:16:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:18:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:20:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:22:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:22:30 PM EDT-Level:150-MEID:56886--MSG: DNZUPX110E The installation of update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" on system "192.168.240.78" was failed. Please check the FFDC log collected on the endpoint. The FFDC log path is "/var/tmp/IBMIMMFFDC/" on the endpoint. And the log will be copied to the IBM Systems Director server later.
August 21, 2013 1:24:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:26:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:26:30 PM EDT-Level:150-MEID:56886--MSG: DNZUPX111I Starting to download FFDC log files to IBM Systems Director server.
August 21, 2013 1:28:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:30:27 PM EDT-Level:150-MEID:56412--MSG: ATKUPD770I Still processing update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" and system "GVICESXI02".
August 21, 2013 1:30:31 PM EDT-Level:150-MEID:56886--MSG: DNZUPX112I Download FFDC log files completed. The files are saved under "/opt/ibm/director/data/sftproot" on this server.
August 21, 2013 1:31:32 PM EDT-Level:50-MEID:56412--MSG: ATKUPD767E The installation of update "ibm_fw_mpt2sas_x240-1.10.09_linux_32-64" was not successful for system "GVICESXI02". Search above for previous related errors, fix each error, and then retry the operation.
August 21, 2013 1:31:32 PM EDT-Level:50-MEID:56412--MSG: DNZUPX027E The attempt to install updates on system "192.168.240.78" was not successful. Search above for previous related errors, fix each error, and then retry the operation. If the error is due to a timeout that occurred while transferring the update from the file server, ensure that there are no firewalls blocking the file server that is used to stage the update or the target system for installation. Also ensure that the required file server port is open. The required port depends on if the file server that is used to stage the update is configured to use TFTP (port 69), FTP (port 21), or SFTP (port 9520). After you have fixed the problem, retry the operation. If the problem persists, check the error logs at path "/opt/ibm/director/lwi/logs" for more details.
August 21, 2013 1:31:32 PM EDT-Level:50-MEID:56412--MSG: ATKUPD705E The update installation request was not successful for system "GVICESXI02". Search above for previous related errors, fix each error, and then retry the operation.
August 21, 2013 1:31:32 PM EDT-Level:100-MEID:56412--MSG: GVICESXI02 client job status changed to "Error".
Administrator Sr. Member Posts: 309 Karma: +6/-0 *****
Re: Node Showing Out of Compliance but isn't
« Reply #1 on: September 04, 2013, 01:17:32 PM »
Welcome to the board!

I had a similar issue and did the following.

First ensure that the CMM firmware is current.

Next I ran inverntory on the CMM from the COMMAND LINE. Never trust a GUI  ;D.

Use this command-
USERID@gvicfsm:~> smcli collectinv -v -p "All Inventory" -i <your CMM IP>
Inventory collection percentage 0%
Inventory collection percentage 35%
Inventory collection percentage 36%
Inventory collection percentage 38%
Inventory collection percentage 69%
Inventory collection percentage 86%
Inventory collection percentage 93%
Inventory collection completed:
100%

Let me know your outcome!!
Super Newbie Posts: 4 Karma: +1/-0 *
Re: Node Showing Out of Compliance but isn't
« Reply #2 on: September 04, 2013, 01:26:44 PM »
Thank you sir!

Not sure what running inventory from the GUI wasn't doing it (I have a task that runs every week) but in any case I'll trust the command line moving forward. After running inventory I now have no systems out of compliance.

Thanks!!

Super Newbie Posts: 9 Karma: +0/-0 *
Re: Node Showing Out of Compliance but isn't
« Reply #3 on: October 09, 2013, 02:20:36 PM »
I had this problem also but just doing inventory didn't work for me. I had to actually reboot the host, once it came back up my compliance warning was cleared.