*
News: SMF - Just Installed!


Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

FSM Update to 1.3.1 Fails via GUI 3492

Administrator Sr. Member Posts: 309 Karma: +6/-0 *****
FSM Update to 1.3.1 Fails via GUI
« on: December 06, 2013, 02:33:30 PM »
All,

I tried 3 times to update my FSM to 1.3.1 from the FSM gui and it bombed on me each time due to not being able to download a single file from IBMs database.

Here are the steps from the Flex System Manager 1.3.1 update ReadMe.

 II. Manually download the fix pack update files from IBM Fix Central
      to a workstation and copy the update files to the FSM.
           
      This method downloads a fix package that consists of two large
      zip files and this readme file.

      1) Go to "http://www.ibm.com/eserver/support/fixes/"

      You can navigate the Fix Central interface as follows or use
      the link below to find Flex System Manager update packages.

      a) To obtain the files from Fix Central using the 'Find Product'
           tab search:
            - Click 'Find product' tab
            - Product Selector -> Enter '8731' or '7955'
            - Operating system -> Select 'All'
            - Click 'Continue'
            - Select 'FSM' to jump to the FSM section of the page
            - Select 'FSMApplianceUpdate-1-3-1' check box
            - Click 'Continue'
            - Follow prompts to enter IBM ID and related machine information
            - If you agree with the terms and conditions on the
                 'View terms and conditions' panel, click 'I agree'
            - Download files using Download Director, ftp, or http.
           
                       
        b) To go directly to the FSM update package and fix page, use the following URL: 

        "http://www-933.ibm.com/support/fixcentral/systemx/selectFixes?parent=Flex+System+Manager+Node&product=ibm/systemx/8731"
       

      2) After obtaining the files, use one of the following methods to
         copy the update files to the /home/USERID directory on the Flex
         System Manager:

         a) Use the scp command (Secure Copy) to send the update package
          files from a workstation on the management or data network to the
          Flex System Manager.
             
          For example, from a remote workstation:

          scp FSMApplianceUpdate-1-3-1-ImportFirst.zip  USERID@<FSM_host_name>:/home/USERID
          scp FSMApplianceUpdate-1-3-1-ImportSecond.zip USERID@<FSM_host_name>:/home/USERID
          scp FSMApplianceUpdate-1-3-1-ImportThird.zip  USERID@<FSM_host_name>:/home/USERID
           

 3) Import and install the updates

         After the files are copied to the Flex System Manager in the
         /home/USERID directory, you must use the command line (through an SSH
         connection) to import and install the updates.  You cannot use the
         Flex System Manager user interface.

         From a command line, run the following commands to collect inventory,
         and import the updates:

          smcli cleanupd -mFv -P "Platform='Director' OR Platform='DirectorAppliance'"
          smcli collectinv -p "All Inventory" -i 10.3.0.1,10.3.0.2 -t OperatingSystem
          smcli importupd -v /home/USERID/FSMApplianceUpdate-1-3-1-ImportFirst.zip
          smcli importupd -v /home/USERID/FSMApplianceUpdate-1-3-1-ImportSecond.zip
          smcli importupd -v /home/USERID/FSMApplianceUpdate-1-3-1-ImportThird.zip
          smcli installneeded -v -F -I

         As the install task is running, messages are displayed in the console. 
         Wait for them to "Complete" successfully.

         If the installation task completed with errors, do not continue. 
         Instead, contact IBM Support and do not restart the Flex System
         Manager.

           
      4) If the installation task completed successfully, restart the
         Flex System Manager to complete the installation processing.

         You can use the command line interface to restart:

         smshutdown -r -t now
         (-r means to restart, '-t now' means to shutdown now.) 
       
         Alternatively, you can use the link provided under the "Flex System
         Manager - Check and Update" link to restart the Flex System Manager.
Administrator Sr. Member Posts: 309 Karma: +6/-0 *****
Re: FSM Update to 1.3.1 Fails via GUI
« Reply #1 on: December 18, 2013, 02:26:46 PM »
Just to confirm this. Once we were able to download the package, the install from the FSM CLI worked.

I will mention that sometimes during a successful install the server hangs on the director server starting screen after reboot and needs to be manually restarted.

Good luck!  8)